Einführung in HTML

Die von den Programmen Turnierplanung und Turnierleitung erzeugten Reports sind HTML-Dateien, ebenso alle vom Turnier-Informationsdienst auf den Monitoren dargestellten Informationen. Alle Programme bedienen sich dabei der Fähigkeit von Browsern (Microsoft Internet Explorer, Google Chrome, Mozilla Firefox, Opera etc.), HTML-Dokumente anzuzeigen und eventuell auch zu drucken.

Die Reports der Programme Turnierplanung und Turnierleitung sind auch geeignet, im Internet veröffentlicht zu werden. Wenn Sie an der Veröffentlichung der Turnierinformationen interessiert sind, dann sollten Sie unbedingt unsere Hinweise und Tipps im Kapitel „Veröffentlichen der Reports“ lesen.

Dieses Kapitel erklärt die Begriffe HTML und CSS, gibt Literaturhinweise und beschreibt, wie Sie das Layout der HTML-Seiten beeinflussen können. Sie brauchen es erst dann durchzuarbeiten, wenn

  • Sie das Layout der Reports von Turnierplanung oder Turnierleitung ändern möchten,
  • Sie das Layout der Seiten im Turnier-Informationsdienst ändern möchten,
  • Sie die Reports von Turnierplanung oder Turnierleitung im Internet veröffentlichen wollen.


Was ist HTML?

HTML (engl. Hypertext Markup Language) ist eine so genannte Auszeichnungssprache, die seit 1990 für die Gestaltung von Seiten im Internet eingesetzt wird. Sie hat die Aufgabe, die logischen Bestandteile eines Dokuments, wie Überschriften, Textabsätze, Listen, Tabellen und auch Grafikreferenzen, zu beschreiben. Hierzu werden HTML-Befehle (engl. Tags) in den darzustellenden Text eingestreut, damit ein bestimmter Textteil als Überschrift, ein anderer als Liste oder als Tabelle und so weiter vom Browser erkannt und dargestellt wird.

Für die Standardisierung der Sprache HTML ist das W3-Konsortium (W3C) verantwortlich. TURNIER-AKTUELL benutzt Sprachelemente der Version 4.01, die im Jahre 1999 spezifiziert wurde.


Externe Stilvorlagen

Externe Stilvorlagen (CSS)

Während in den HTML-Dateien prinzipiell die Struktur der Dokumente beschrieben wird, lässt sich über externe Stilvorlagen (CSS für engl. Cascading Style Sheets) die visuelle Darstellung der Dokumente beeinflussen.

Sie können über CSS einwirken auf

  • Schrift- und Textgestaltung,
  • Positionierung und Anzeige von Elementen,
  • Ausrichtung und Absatzkontrolle,
  • Abstände, Rahmen, Farben und vieles mehr.

Der Vorteil separater Stilvorlagen ist, dass Sie als Anwender Einfluss auf das Aussehen der in HTML erstellten Dokumente nehmen können. Während die HTML-Dateien von den Programmen jedes Mal neu geschrieben werden, haben Sie in der Stilvorlagendatei einmal die Art und Weise festgelegt, wie diese aussehen sollen.

Die Möglichkeit zur Formatsteuerung über CSS existiert seit 1996. Damals wurde vom W3C die Spezifikation für CSS Level 1 herausgegeben. 1998 erschien dann die zweite Spezifikation (CSS Level 2) mit wesentlich mehr Informationen. Seit 2000 ist CSS Level 3 in der Entwicklung.


Literaturhinweise zu HTML und CSS

Wenn Sie mehr zu den Sprachstandards HTML und CSS oder anderen Themen rund ums Internet erfahren möchten, dann empfehlen wir Ihnen die Einstiegsseite „http://www.w3.org“ des W3-Konsortiums. Das W3C unterhält auch Auslandbüros (siehe „http://www.w3.org/Consortium/Offices“), unter anderem ein deutsches Büro. Dort finden Sie deutsche Übersetzungen vieler W3C-Dokumente.

Wer eigene Seiten für den Turnier-Informationsdienst erstellen oder die mitgelieferten Stilvorlagen ändern möchte, kommt wahrscheinlich nicht ohne entsprechende Literatur aus. Bücher über HTML finden Sie in jeder gut sortierten Buchhandlung. Es gibt aber auch verschiedene Online-Lektüren im Internet. Wir empfehlen die Online-Dokumentation SELFHTML, eine sehr gute und leicht verständliche Beschreibung für HTML, CSS und vieles mehr. SELFHTML ist gleichermaßen für Anfänger, Fortgeschrittene und Profis interessant.

Aktuell ist derzeit die Version 8.1.2 vom März 2007. Über die internationale Portalseite „http://www.selfhtml.org“ gelangen Sie sowohl zur Dokumentation SELFHTML als auch zu den erweiterten Angeboten wie Forum, Chat, Linkverzeichnis usw.


Benutzeränderungen in den Stilvorlagen

Die Verwendung externer Stilvorlagen haben wir deshalb gewählt, damit Sie als Anwender Einfluss auf die Präsentation der Reports und TID-Anzeigen nehmen können.

Die Stilvorlagen können mit einem einfachen Texteditor bearbeitet werden. Es empfiehlt sich, die zugehörige HTML-Datei vor und nach dem Ändern von Stilvorlagen im Browser zu kontrollieren.

Änderungen kontrollieren

Im Allgemeinen reicht ein Doppelklick auf die HTML-Datei, um diese im Browser anzuzeigen. Nachdem Sie Änderungen in der CSS-Datei vorgenommen und gespeichert haben, brauchen Sie im Browser die angezeigte Seite nur aktualisieren, um das Ergebnis Ihrer Änderung zu kontrollieren. Je nach verwendetem Browser erreichen Sie die Aktualisierung der Seite über die Schaltfläche [AKTUALISIEREN] oder [NEU LADEN]. Lesen Sie dazu die Bedienungsanleitung für Ihren Browser.

Sorgfältiges Arbeiten

Allen Anwendern möchten wir den Hinweis mitgeben, dass Änderungen sehr sorgfältig durchzuführen sind.

Wie oben schon erwähnt, unterstützen nicht alle Browser den vollen Sprachumfang von CSS Level 2. In der Regel werden diese CSS-Eigenschaften von neueren Browsern ignoriert und führen nur noch in seltenen Fällen zu einem Browserabsturz. Manche CSS-Interpretationen sind aber auch fehlerhaft implementiert und führen dann nicht zu dem gewünschten Ergebnis. Manchmal sind es aber eigene Schreibfehler, die dazu führen, dass Stilelemente nicht interpretiert werden. Bei Schreibfehlern haben Sie keine Unterstützung von den Browsern zu erwarten: Alles, was der Browser nicht kennt, wird einfach ignoriert. Sie erhalten keine Meldung. Wir empfehlen Ihnen deshalb, die geänderten CSS-Dateien mit einem Validator (siehe Kapitel „Testen und Validieren der HTML-Dateien“) zu überprüfen.

Vorgehensweise

Die Formatdefinitionen beziehen sich in der Regel auf jeweils ein HTML-Element in Verbindung mit einer Klasse. Diese Selektor-Schreibweise erscheint auf den ersten Blick etwas umständlich und optimierungsbedürftig, sie hat aber den Vorteil, dass auch Benutzer, die bisher noch keine Erfahrungen mit HTML und CSS haben, gezielte Anpassungen in den Stilvorlagen vornehmen können.

Für Neulinge auf dem Gebiet der HTML- und CSS-Programmierung empfehlen wir, am Anfang nur einfache Stiländerungen vorzunehmen. Einfache Änderungen sind beispielsweise das Ändern der Farben (CSS-Eigenschaften color oder background-color), das Ausblenden von Dokumentteilen (display: none), die Festlegung fixer Spaltenbreiten in Tabellen (width) oder das Einfügen oder Entfernen von Seitenumbrüchen (page-break-before oder page-break-after) im Ausdruck.

Tiefgreifende Änderungen sollten Sie allerdings nur vornehmen, wenn Sie auch über die notwendigen Erfahrungen in HTML und CSS verfügen.

Allgemein gilt die Empfehlung, immer nur eine Änderung vorzunehmen und das Ergebnis, wie im Kapitel „Testen und Validieren der HTML-Dateien“ beschrieben, gleich zu kontrollieren.


Stilvorlagen für die Programme Turnierplanung und Turnierleitung

Die HTML-Dateien und ihre zugehörigen Stilvorlagen finden Sie im Unterverzeichnis „/Reports“. Schauen Sie in den entsprechenden Handbüchern der beiden Programme nach, welche HTML- und CSS-Dateien zusammengehören.

Grundaufbau der Stilvorlage

Bei den CSS-Dateien haben wir darauf geachtet, dass alle Dateien möglichst einheitlich aufgebaut sind. Der erste Abschnitt definiert jeweils den Schriftsatz, der mittlere Abschnitt bezieht sich auf medienabhängige Definitionen, und im letzten Teil werden die Formate für den eigentlichen Inhalt (Daten) der HTML-Dokumente definiert.

Kommentare innerhalb von CSS-Dateien

Innerhalb der Stildefinitionen sind Kommentare eingefügt, um die Bedeutung der einzelnen Definitionen für Anwender ohne HTML-Erfahrungen zu beschreiben. Durch die Kommentarkennzeichen können Sie beim Bearbeiten der CSS-Dateien auch einzelne Definitionen herausnehmen, ohne diese sofort löschen zu müssen. Kommentare werden am Anfang mit „/*“ und am Ende mit „*/“ eingegrenzt.

Festlegung der Schriftart

Der erste Abschnitt definiert die Schriftart, mit welcher das HTML-Dokument dargestellt werden soll. Durch die Definition für das Body-Element beziehen sich die Angaben auf alle Textelemente der HTML-Datei.

Vorgaben für unterschiedliche Ausgabemedien

Die nächsten Zeilen helfen, unterschiedliche Formatierungen für die Bildschirmpräsentation (engl. Screen) und für den Druck (engl. Print) zu definieren:

     @media screen {
             /* …Angaben zur Bildschirmanzeige… */
     }
     @media print {
             /* …Angaben zum Drucken… */
     }

Alle Angaben zwischen den geschweiften Klammern „{…}“ gelten nur für das jeweilige Ausgabemedium.

Unterscheidungen sind beispielsweise für das Seitenlayout und den Seitenumbruch sinnvoll. Am Bildschirm werden die Informationen als Endlos-Dokument dargestellt und die einzelnen Abschnitte meist durch einen ein oder zwei Zentimeter hohen Freiraum (CSS-Eigenschaft line-height) optisch getrennt. Im Ausdruck bietet sich häufig an, nachfolgende Abschnitte auf einer neuen Seite (page-break-after: always) beginnen zu lassen.

Ein anderes Beispiel für eine medienabhängige Darstellung ist die Anzeige beziehungsweise Nichtanzeige von Elementen. Standardmäßig haben wir den Ausdruck von Verweisen durch die CSS-Eigenschaft display: none unterdrückt. Aber auch ganze Abschnitte (div-Elemente) lassen sich unterdrücken, so beispielsweise der Ausdruck des Inhaltsverzeichnisses. Dafür wäre dann in der CSS-Datei die nachfolgende Definition aufzunehmen:

     div.Verzeichnis {
             display: none;
     }

Formatangaben für den Datenteil

Hinter den medienspezifischen Definitionen finden Sie die allgemeinen Stilvorlagen. Dieser Abschnitt enthält unter anderem die Definitionen zur Formatierung der Texte und Überschriften (Schriftart, Schrifttyp und Schriftgröße) und zur Gestaltung von Tabellen (Spaltenbreite, Zeilenhöhe).

Tabellen werden in den HTML-Dateien aus zwei Gründen benutzt. Zum einen werden Tabellen definiert, um Daten tabellarisch darzustellen. Zum anderen dienen Tabellen als Hilfsmittel für das Seitenlayout, um Text und Grafik sauber ausrichten und relativ frei verteilen zu können. Tabellen mit gestalterischen Aufgaben sind meist ohne Gitternetzlinien und deshalb vom Betrachter als solche nicht zu erkennen.

Unterscheidung von Titelblatt und Einzelblatt

Bei der ersten Seite wird in manchen Fällen zwischen den Gesamtdokumenten oder Teildokumenten unterschieden. Die Spielerliste für alle Mannschaften wäre das Gesamtdokument, die Spielerliste einer einzelnen Mannschaft dementsprechend ein Teildokument. Demzufolge werden für den ersten Abschnitt (div-Element) unterschiedliche Klassen verwendet. Im Gesamtdokument ist es das div-Element der Klasse „Titelblatt“, in der einzelnen Spielerliste ist es das div-Element der Klasse „Einzelblatt“.

Einfügen des Vereinswappens

Innerhalb des ersten Abschnitts ist vorgesehen, dass der Name des Turniers und das Wappen des Veranstalters angezeigt werden. Das Wappen muss im Grafikformat GIF vorliegen, und die Datei muss „verein.gif“ heißen und im Unterverzeichnis „/Reports“ liegen. Liegt die Datei nicht vor, so wird ersatzweise der Text „Vereinswappen“ angezeigt. Möchten Sie auf das Vereinswappen verzichten, können Sie mit der CSS-Eigenschaft display: none in „img.Verein“ die Anzeige des Wappens beziehungsweise des Alternativtextes unterdrücken.

Anmerkung: Nach der Installation von TURNIER-AKTUELL finden Sie eine Datei „verein.gif“, die einen Fußball darstellt. Sie können diese Datei durch Ihre eigene Bilddatei „verein.gif“ ersetzen.


Stilvorlagen für den Turnier-Informationsdienst

Die HTML-Seiten mit den Spielplänen, Ergebnissen und Tabellen im Mittelteil sowie den aktuellen Spielständen im Fußteil werden automatisch erstellt. Die visuelle Darstellung wird über die Stilvorlage „allCSS.css“ festgelegt. Außerdem sind die vier Stilvorlagen „TurnierTitel.css“, „TurnierBottom.css“, „LinkerRand.css“ und „RechterRand.css“ vorhanden, damit Sie bei wechselnden Kopf-, Rand- und Fußanzeigen auf dieselbe Stilvorlage zurückgreifen können.

Alle genannten Stilvorlagen finden Sie im Unterverzeichnis „/html_in“. Bei der Übernahme der Bilder (siehe Benutzerhandbuch Turnier-Informationsdienst) werden die aktuellen Versionen in das Verzeichnis „/html_out“ übertragen.

Stilvorlage „allCSS.css“

Sämtliche automatisch erzeugten (dynamischen) HTML-Seiten, ob Spielpläne, Ergebnisse, Tabellen im Mittelteil oder aktuelle Spielstände im Fußteil, benutzen die externe Stilvorlage „allCSS.css“.

Diese CSS-Datei definiert die optische Gestaltung aller dynamischen Seiten. Die Namen der Klassen enthalten normalerweise ein Präfix („tabelle_“, „ergebnis_“), das auf die entsprechende HTML-Seite hinweist.

Die meisten Formatdefinitionen beziehen sich auf den Zeichensatz (font-family), die Schriftgröße (font-size) und die Darstellungsbreite (width).

Stilvorlage „Turniertitel.css“

Die Datei „Turniertitel.htm“ ist unser Vorschlag, wie Sie den Kopf der TID-Anzeige gestalten können. Diese Datei verwendet die externe Stilvorlage „TurnierTitel.css“.

Mit der externen Stilvorlage können Sie also mehrere HTML-Dateien, beispielsweise „TurnierTitel_1.htm“, „TurnierTitel_2.htm“ usw., mit unterschiedlichen Inhalten für den Kopfteil anlegen, wobei die optische Darstellung für alle HTML-Seiten nur einmal in der CSS-Datei definiert wird. So reicht es aus, die Schriftgröße oder die Hintergrundfarbe in der Stilvorlage zu ändern, damit alle Kopfdateien im neuen Format erscheinen.

Stilvorlage „TurnierBottom.css“

Die Datei „TurnierBottom.htm“ ist unser Vorschlag, wie Sie den Fuß der TID-Anzeige gestalten können. Diese Datei verwendet die externe Stilvorlage „TurnierBottom.css“.

Mit der externen Stilvorlage können Sie also mehrere HTML-Dateien, beispielsweise „TurnierBottom_1.htm“, „TurnierBottom_2.htm“ usw., mit unterschiedlichen Inhalten für den Fußteil anlegen, wobei die optische Darstellung für alle HTML-Seiten nur einmal in der CSS-Datei definiert wird. So reicht es aus, die Schriftgröße oder die Hintergrundfarbe in der CSS-Datei zu ändern, damit alle Fußdateien im neuen Format erscheinen.

Stilvorlage „LinkerRand.css“

Die Datei „LinkerRand.htm“ ist unser Vorschlag, wie Sie den linken Rand neben dem Mittelteil gestalten können. Diese Datei verwendet die externe Stilvorlage „LinkerRand.css“.

Mit der externen Stilvorlage können Sie also mehrere HTML-Dateien, beispielsweise „LinkerRand_1.htm“, „LinkerRand_2.htm“ usw., mit unterschiedlichen Inhalten für den linken Anzeigerand anlegen, wobei die optische Darstellung für alle HTML-Seiten nur einmal in der CSS-Datei definiert wird. So reicht es aus, die Schriftgröße oder die Hintergrundfarbe in der CSS-Datei zu ändern, damit alle Fußdateien im neuen Format erscheinen.

Stilvorlage „RechterRand.css“

Die Datei „RechterRand.htm“ ist unser Vorschlag, wie Sie den linken Rand neben dem Mittelteil gestalten können. Diese Datei verwendet die externe Stilvorlage „RechterRand.css“.

Mit der externen Stilvorlage können Sie also mehrere HTML-Dateien, beispielsweise „RechterRand_1.htm“, „RechterRand_2.htm“ usw., mit unterschiedlichen Inhalten für den rechten Anzeigerand anlegen, wobei die optische Darstellung für alle HTML-Seiten nur einmal in der CSS-Datei definiert wird. So reicht es aus, die Schriftgröße oder die Hintergrundfarbe in der CSS-Datei zu ändern, damit alle Fußdateien im neuen Format erscheinen.


Veröffentlichen der Reports

Die Reports der Programme Turnierplanung und Turnierleitung sind geeignet, um im Internet veröffentlicht zu werden. Darüber hinaus kann es wünschenswert sein, Seiten, die für den Turnier-Informationsdienst vorbereitet wurden, ebenfalls zu veröffentlichen.

Dieses Kapitel erklärt Ihnen, wie Sie den Internet-Auftritt Ihres Turniers planen und verwirklichen können.

Voraussetzungen

Für die Veröffentlichung der Turnierinformationen im Internet sind die folgenden Voraussetzungen und Schritte notwendig:

  • Sie müssen die Turnierinformationen in Ihre bestehende Internet-Präsenz integrieren.
  • Sie sollten, sofern Sie die HTML- oder CSS-Dateien verändern, die Dateien testen und validieren.
  • Sie müssen alle HTML-Dateien, die darin aufgerufenen Bilder und die Stilvorlagen auf einem Web-Server abspeichern.
  • Sie müssen die Verfügbarkeit der HTML-Dateien bekannt machen.

Sobald die Dateien öffentlich zugänglich sind, sind Sie dafür verantwortlich, diese zu aktualisieren und, wenn sie nicht mehr relevant sind, zu löschen.

Integration in die bestehende Internet-Präsenz

Die Reports von TURNIER-AKTUELL sind eine lose Ansammlung von Internetseiten rund um das Turnier. Jede HTML-Datei stellt eine Internetseite dar. Was jetzt noch fehlt, sind die Verweise (engl. Hyperlinks) für den Leser, um an die Informationen zu gelangen.

Dazu müssen Sie sich überlegen, zu welchen anderen, bereits vorhandenen Informationen die neuen Internetseiten passen und wie Sie nun die Turnierinformationen in bestehende Strukturen integrieren.

Fügen Sie Hyperlinks in Ihre bestehenden Webseiten ein, die dem Leser den Zugang zu den Turnierinformationen ermöglichen.

Außerdem sollten Sie die Internetseiten des Turniers farblich mit Ihren bestehenden Seiten abstimmen. Verändern oder ergänzen Sie dafür die externe Stilvorlagendatei.

Testen und Validieren der HTML-Dateien

Die von TURNIER-AKTUELL jeweils neu erstellten Reports und die mitgelieferten externen Stilvorlagen (CSS-Dateien) stellen nur Vorschläge dar, wie Sie die Turnierinformationen im Internet präsentieren können. Vermutlich werden Sie aber Hand anlegen, um die Seiten nach Ihrem Geschmack und passend zu den bereits publizierten Webseiten zu veröffentlichen.

Diese Anpassung geschieht lokal auf Ihrem PC, indem Sie die HTML- oder CSS-Dateien mit einem Text- oder Web-Editor nachbearbeiten und die Ergebnisse mit einem Browser kontrollieren.

Sie sollten sich aber nicht auf die rein optische Kontrolle verlassen. Ihre Dateien können immer noch Syntaxfehler enthalten, die durch die Fehlertoleranz Ihres Browsers aber nicht aufgedeckt werden. Wir empfehlen daher die Benutzung von Prüfprogrammen („Validatoren“), die vergleichbar mit der Rechtschreibprüfung in der Textverarbeitung die Einhaltung der Sprachregeln kontrollieren. Nur so können Sie die Brauchbarkeit Ihrer Dateien für die verschiedenen Browser sicherstellen.

Solche Prüfprogramme können Sie lokal auf Ihrem PC installieren. Wesentlich einfacher und bequemer ist es aber, einen öffentlichen Validierungsservice zu verwenden. Wir empfehlen die Validatoren des W3C (https://validator.w3.org). Wenn Sie die Upload-Funktion benutzen, können Sie Ihre lokalen HTML- oder CSS-Dateien prüfen, ohne die Dateien vorher zu Ihrem Web-Server transferieren zu müssen.

Abspeichern der HTML-Dateien

Wenn Sie die Turnierinformationen veröffentlichen wollen, sollten Sie die nachfolgenden Hinweise beziehungsweise Empfehlungen beachten:

  • Die Reports von Turnierplanung und Turnierleitung sind so aufgebaut, dass alle Dateien (HTML-, CSS-, Bilddateien) in einem Unterverzeichnis gespeichert werden müssen. Richten Sie also ein Unterverzeichnis auf dem Web-Server ein, in welches die Dateien abgelegt werden sollen.
    Sie können aber auch die Dateien gemäß Ihrem eigenen Speicherkonzept ablegen. In diesem Falle müssten Sie in den HTML-Dateien die Referenzen auf die CSS- und Bilddateien anpassen. Wir empfehlen daher die Einrichtung eines alle Dateien umfassenden Unterverzeichnisses.
  • Um die Turnierinformationen im Internet bereitstellen zu können, brauchen Sie ausreichend Speicherplatz auf Ihrem Web-Server. Prüfen Sie vor dem Dateitransfer, ob der Speicherplatz auf Ihrem Web-Server ausreicht.
  • Manche Web-Server arbeiten mit einem Betriebssystem, bei dem die Groß- und Kleinschreibung der Dateinamen eine wichtige Rolle spielt (z. B. UNIX). Achten Sie deshalb darauf, dass die Dateinamen und die Referenzen in den HTML-Dateien einheitlich geschrieben werden. Verwenden Sie möglichst keine Sonderzeichen in den Dateinamen.
  • Übertragen Sie nur Seiten, die Sie zuvor getestet und validiert (siehe Kapitel „Testen und Validieren der HTML-Dateien“) haben.
  • Übertragen Sie zuerst die neuen Internetseiten mit den Turnierinformationen und erst danach die geänderten Seiten, die auf die neuen Internetseiten verweisen.
  • Prüfen Sie nachfolgend auch, ob die Dateien mit weltweiter Leseberechtigung versehen sind.

Bekanntmachen der Internetseiten

Die schönsten Internetseiten nützen nichts, wenn niemand erfährt, dass und wo es sie gibt. Nachdem nun die Internetseiten auf dem Web-Browser zur Verfügung stehen, sollten Sie deren Existenz und Internetadresse (URL als Abkürzung für engl. Uniform Resource Locator) in geeigneter Weise bekannt machen.

Verweise in den Vereinsseiten

Zum einen haben Sie bereits Verweise (engl. Hyperlinks) in Ihre Vereinsseiten eingefügt. Damit können alle Leser, welche die Vereins-Homepage besuchen, dann auch zu den Turnierinformationen gelangen.

Meta-Tags für Suchmaschinen

Zum anderen sind so genannte Spider und Robots von Suchmaschinen unterwegs, die in verschiedenen Zyklen nach Änderungen in Webseiten oder nach neu hinzugekommenen Webseiten suchen. Aus diesen Informationen wird ein Index generiert. Wenn eine Suche gestartet wird, dann wird in der Regel nicht das gesamte Internet, sondern nur der aufgebaute Index durchsucht.

In den Reports von TURNIER-AKTUELL sind bereits erste Hilfen, nämlich ein Seitentitel und ein paar Meta-Angaben (engl. Meta-Tags), für die Suchmaschinen eingebaut.

Mehr Informationen, wie Sie Ihre Seiten bekannt machen können, finden Sie im Internet, beispielsweise im bereits erwähnten SELFHTML-Wiki oder auf Internetseiten mit Tipps und Tricks zum Thema Suchmaschinen-optimierte Gestaltung von Webseiten.

Aktualisieren der Internetseiten

Sie als Autor sind dafür verantwortlich, alle im Internet veröffentlichten Informationen aktuell zu halten, also bei Bedarf zu korrigieren oder, falls nicht mehr relevant oder nicht länger aktualisiert, zu löschen. Denn falsche oder nicht mehr aktuelle Informationen sind schlechter als gar keine Informationen.

Für die Aktualisierung könnte es hilfreich sein, die Leser um Mithilfe zu bitten. Wir empfehlen deshalb, auf Ihren Webseiten eine E-Mail-Adresse zu veröffentlichen, an die Ihre Leser Fragen, Hinweise auf Probleme und Verbesserungsvorschläge senden können.


Browser

Browser-Anforderungen

Erforderliche Web-Browser-Kompatibilität

Grundsätzlich können Sie jeden Browser benutzen, der HTML Version 4.01 und CSS Version 2 unterstützt. Außerdem sollte der Browser die Ausgabe auf Druckern gut unterstützen, sofern Sie die Reports schnell und ohne Umweg ausdrucken wollen.

Alternative Methode für das Ausdrucken

HTML-Browser sind kein Ersatz für Desktop-Publishing-(DTP-)Systeme. Dennoch ist es wünschenswert, dass die Reports der Programme Turnierplanung und Turnierleitung korrekt ausgedruckt werden. Obwohl in der Spezifikation von CSS Version 2 bereits die Unterstützung von Druckern aufgenommen wurde, haben unsere Testergebnisse jedoch Probleme bei verschiedenen älteren Browsern (vor 2010) aufgedeckt.

Für alle, die mit den Druckergebnissen ihres Browsers nicht zufrieden sind, gibt es immer noch die Möglichkeit, das HTML-Dokument mit einem Textverarbeitungsprogramm (z. B. Microsoft Word) oder einem DTP-Programm (Adobe Pagemaker, Microsoft Publisher, QuarkXpress) nachzubearbeiten und dann zu drucken.


Impressum

Dieses Dokument enthält urheberrechtlich geschützte Informationen. Alle Rechte vorbehalten. Ohne die vorherige schriftliche Genehmigung des Copyright-Inhabers darf kein Teil dieser Dokumentation in irgendeiner Form durch Fotokopie, Mikrofilm oder andere Verfahren reproduziert oder in eine für elektronische Systeme verwendbare Sprache übertragen werden. Auch die Rechte der Wiedergabe durch Vortrag, Funk und Fernsehen sind vorbehalten.

Änderungen an der Dokumentation und der darin beschriebenen Produkte ohne vorherige Bekanntmachung bleiben vorbehalten.

Bei der Zusammenstellung von Texten und Abbildungen wurde mit größter Sorgfalt vorgegangen. Wir können jedoch für eventuell verbliebene technische oder typografische Fehler und deren Folgen weder eine juristische Verantwortung noch irgendeine Haftung übernehmen. Für Verbesserungsvorschläge und Hinweise auf Fehler sind wir jedoch stets dankbar.

Wir gewährleisten nicht, dass Änderungen an Software und Hardware anderer Hersteller, auf die in diesem Handbuch Bezug genommen wird, ohne Auswirkungen auf die Anwendbarkeit der in dem Handbuch enthaltenen Informationen bleiben.

Die in diesem Handbuch beschriebene Software wird unter einer Lizenzvereinbarung bereitgestellt. Die Benutzung und Vervielfältigung des Programms erfolgt ausschließlich aufgrund dieser Lizenzbestimmungen, die dem Produkt beiliegen.

Die Informationen in diesem Handbuch werden ohne Rücksicht auf einen eventuellen Patentschutz veröffentlicht. Warennamen werden ohne Gewährleistung der freien Verwendbarkeit benutzt. Die in den Beispielen verwendeten Namen und Daten sind frei erfunden, soweit nichts anderes angegeben ist. Jede Ähnlichkeit mit tatsächlichen Firmen, Personen, Namen oder Daten ist rein zufällig.

Copyright © Karlheinz Faltermann – Alle Rechte vorbehalten.